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DIGITAL ANALYSIS OF BATTERY SEPARATOR 

STRUCTURES 

INTRODUCTION 

MOTIVATION 

Even though battery separators are not an active part of the Li-ion battery assembly, 
the microstructure of the separator affects ion transport and has a considerable 

impact on the overall performance and lifetime of the battery. Understanding the 
influence of the separator microstructure on the battery performance opens a vast 
potential for improvement of battery design. 

This tutorial illustrates the capabilities of the GeoDict software to digitally analyze and 
optimize the microstructure of battery separators. Following the tutorial, the user 

learns to import and crop the pre-processed microstructure of a segmented FIB-SEM 
scan of a Celgard® PP1615 Lithium-Ion Battery Separator in GeoDict. Then, the user 

calculates the geometric (morphological) and transport properties of the 
microstructure and identifies a representative elementary volume (REV). On this REV, 
the electrolyte-separator interaction is computed, and mechanical deformation is 

simulated. The geometric and transport properties are then discussed for the 
mechanically deformed structures as well.  

BACKGROUND OF THE SAMPLE 

The tutorial deals with the analysis of a sample of binarized focused ion beam 
scanning electron microscopic (FIB-SEM) tomography image stacks of a polymer-

based separator microstructure. The scan of a Celgard® PP1615 Lithium-Ion Battery 
Separator was created by the MaDE group at ETH Zürich and can be accessed via 

https://doi.org/10.3929/ethz-b-000265085 . 

The scan was preprocessed at Math2Market to import the binarized data to the 
GeoDict structure format .gdt. The preprocessed structure is provided in the folder 

Input-Data, inside the provided tutorial folder. 

 

 

Disclaimer: 

The work for this tutorial was not endorsed nor funded by ETH Zurich 

https://doi.org/10.3929/ethz-b-000265085


Digital analysis of battery separator structures 

2  Tutorial for GeoDict 2024 

HOW TO USE THIS EXAMPLE TUTORIAL 

The tutorial is organized into six parts that explain how to perform the computations 
step-by-step in the GeoDict GUI (Graphical User Interface). To proceed faster, the 

intermediate results can be loaded from the Results-M2M folder inside the Digital-
analysis-of-battery-separator-structures.  

The six steps are: 

1. Importing and cropping the structure: 

Load the FIB-SEM data and crop a segment for the computations. 

2. Computing geometric and transport properties:  

Compute geometric and transport properties of the cropped structure, like 
porosity, tortuosity, Euler characteristics, Gurley value and permeability. 

3. Identifying a REV for geometric properties:  

Identify a representative elementary volume (REV) of the structure for the 

computation of porosity and tortuosity. 

4. Computing separator-electrolyte interaction:  

Compute the thermal conductivity dependent on the wetting of the separator 

with electrolyte. 

5. Computing the deformed structure for REV:  

Compute the deformation for a mechanical load. 

6. Computing properties of deformed structure:  

Compute geometric and transport properties again for the deformed geometries. 

 

  

Modules needed to follow this tutorial: 
GeoDict-Base, MatDict, DiffuDict, FlowDict, SatuDict, 
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Three folders and this PDF file are inside the Digital-analysis-of-battery-

separator-structures folder. 

 

◼ The Input-Data folder contains the segmented FIB-SEM data used as input 
structure for the computations in this tutorial and a GeoPy script (*.py) to 

identify an REV. 

 

◼ The Results-User folder is empty. We recommend that, before starting to 

work through this tutorial, the user sets the Results-User folder as project 
folder in GeoDict.  

For this, in the GeoDict GUI, select File → Choose Project Folder → Select 

Project Folder and navigate to the folder Results-User. In this way, the 
result files created when running the tutorial will not overwrite the files 
provided by Math2Market, even when using the same names. 

◼ The Results-M2M folder contains the results that we at Math2Market 
obtained by following this tutorial.  

Most of the results from each of the tutorial parts consist (as always in GeoDict) of a 

GeoDict result file (*.gdr) and a corresponding folder with the same name.  
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These files and folders are described in the following in the order shown above: 

1. Cropped REV used in this tutorial to compute several properties for the separator: 
Celgard_PP1615_300x300x300_M2M.gdt 

2. Separator before cropping but already with materials info set-up: 
Celgard_PP1615_WithMaterialInfo.gdt 

3. GeoDict result files created by performing deformation simulations using the 
ElastoDict module once simulating 5% deformation and once 10%:. The results 
can be found in the accompanying folder: 
DeformationResult_5%_300x300x300_M2M.gdr 

DeformationResult_10%_300x300x300_M2M.gdr 

4. GeoDict result files created by computing the tortuosity using the DiffuDict 
module once on the original cutout of the structure, once after 5% deformation, 
and once after 10%:  

Diffusion_300x300x300_M2M.gdr 
Diffusion_300x300x300_Def5%_M2M.gdr 

Diffusion_300x300x300_Def10%_M2M.gdr 

5. GeoDict result file created by computing the Euler characteristics using the 
MatDict module on the original cutout of the structure: 
MinkowskiParameters_300x300x300_M2M.gdr 

6. GeoDict result files created by computing the separator-electrolyte interaction 
using the ConductoDict module once on the original cutout of the structure, once 

after 5% deformation, and once after 10%: 
RelConductivity_300x300x300_M2M.gdr 

RelConductivity_300x300x300_Def5%_M2M.gdr 
RelConductivity_300x300x300_Def10%_M2M.gdr 

7. GeoDict result file created by computing the permeability using the FlowDict 
module on the original cutout of the structure: 

StokesResult_300x300x300_M2M.gdr 

8. GeoDict result files created by computing the porosity and other structure 
statistics using the MatDict module once on the original cutout of the structure, 
once after 5% deformation, and once after 10%: 
StructureInformation_300x300x300_M2M.gdr 

StructureInformation_300x300x300_Def5%_M2M.gdr  
StructureInformation_300x300x300_Def10%_M2M.gdr 

9. IdentifyingREV_M2M folder containing the results of the parameter study 
computing tortuosity and porosity for different cutout sizes. The results are 

combined in the plot Plot_IdentifyingREV.png 
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1. IMPORTING AND CROPPING THE STRUCTURES 

Before starting the simulations, set-up the project folder as described on page 3.  

1. Load the binarized example separator structure in GeoDict. For this, select File 
→ Open Structure (*.gdt, *.gad)… from the menu bar and browse for the 

Input-Data folder inside the tutorial folder.  

2. Select the file Celgard_PP1615_Polypropylene.gdt and click Open. 

 

The structure is loaded in GeoDict. 

The structure appears in 2D in the Visualization area of the GeoDict GUI with the 
built-in visualization and view settings. 

1.1 VISUALIZATION SETTINGS 

To obtain the display below, proceed as follows: 

 

1. Above the visualization area, in the View Controls panel, go to the Camera tab 

and set the Direction to Z. 
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2. Change the color of the material with ID 01 from red to gray through the Color & 
Visibility tab from the side bar on the right of GeoDict. 

 

3. Click the 3D visualization icon  in the toolbar or select View → 3D Rendering 

to display the structure in 3D view.  

4. In the Camera tab check Show Outlines and Show Halo. For the camera angle 

we set the Rotation values as follows: 

◼ HDG 20 

◼ ATT 10 

◼ BNK 20 

 

5. For a smooth representation of the structure, select Structure Renderer → 

Smooth under the Structure tab in the Visualization panel. 
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For this loaded segment of a polypropylene separator, the X-axis and Z-axis 

correspond to the in-plane directions of the separator, and the Y-axis indicates the 
through-plane direction.  
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1.2 ASSIGN MATERIAL PROPERTIES 

Now, assign materials to the pore and solid part of the structure.  

1. Select Model → ProcessGeo in the menu bar.  

In the ProcessGeo module section, now appearing on the left of the GeoDict GUI, 

choose Reassign Materials & IDs from the first pull-down menu, and Reassign 
Material of Material ID from the second. 

Click Edit… to open the options dialog. 

 

2. For the pore voxels with Material ID 00, set the New Material to Electrolyte 
(Fluid) by clicking on the box and selecting the material from the Material 
Selector and click OK.  
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Click again OK in the Reassign Material of Material ID dialog and then 

Reassign in the ProcessGeo module section. 

3. Repeat the same procedure to assign the material Polypropylene (Solid) to 
the solid part of the structure with Material ID 01. 

 

The new material information is now shown above the structure in the GeoDict 
Visualization area. Properties of the constituent materials (Electrolyte, 

Polypropylene) are taken from the GeoDict Material Database and can now be used 
for the computations, where not only the geometric properties of the structure are 
relevant. Note that the material properties are not the specific ones of the Celgard® 

Separator structure used here. 

 

4. Select File → Save Structure as… in the menu bar to save the structure 

together with the material information in the project folder. Choose the filename 

Celgard_PP1615_WithMaterialInfo.gdt. 

  



Digital analysis of battery separator structures 

10  Tutorial for GeoDict 2024 

1.3 CROP STRUCTURE 

Lagadec et al.[1] have reported that a segment of 3µm length in each coordinate 
direction is a representative elementary volume (REV) for this polypropylene 

separator regarding porosity, tortuosity, connectivity, and the effective transport 
coefficient. 

To pick a segment of 3µm side length, the structure is cropped using the ProcessGeo 

module as follows: 

1. Select Model → ProcessGeo in the menu bar. 

2. In the ProcessGeo module section, select Crop, Embed & Add Layers from the 

first pull-down menu and Crop from the second one. 

Then, click Edit to open the options dialog. 

 

3. Crop the sample in each direction to 300 voxels. For this, enter the values 0 – 
300 for NX, NY and NZ. Click OK to close the dialog, then click Crop in the 
ProcessGeo section to start the cropping process. 
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The smaller structure is now displayed in the Visualization area. 

 

4. Select File → Save Structure as... or the corresponding icon in the toolbar  

to save the cropped segment of the structure with the filename 

Celgard_PP1615_300x300x300.gdt in the project folder. 
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2. COMPUTING GEOMETRIC AND TRANSPORT PROPERTIES  

In the second step, different geometric and transport properties are computed on the 

cropped segment.  

1. Select the Results-User folder as project folder, as described on page 3.  

2. Load the cropped segment of size 300x300x300 (unless it is still in memory) as 
follows: File → Open Structure (*.gdt, *.gad)… and select the 

Celgard_PP1615_300x300x300.gdt file from the project folder or from the 

Results-M2M folder.  

 

2.1 POROSITY 

Now, let’s obtain the porosity of the structure as follows:  

1. Find the Project Status panel on the left side of the GeoDict GUI. Here, unfold the 

Statistics section. Expand the 3D section and the list of Material IDs, to observe 
the volume percentage for each material ID. The original pore space (now filled 
with Electrolyte) occupies 41.93% of the segment, i.e., the porosity is 41.93%. 

 

2. To get a GeoDict result file containing the porosity value, select Analyze → 

MatDict from the menu bar. 

In the MatDict module section, on the left of the GeoDict GUI, select Material 
Statistics from the first pull-down menu and Structure Information from the 
second one. Then click Edit… to open the options dialog. 
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3. In the Structure Information dialog that opens, define the Result File Name as 

StructureInformation_300x300x300.gdr and close the dialog by clicking OK. 

 

Start the computation by clicking Run in the MatDict module section. 

4. The Result Viewer of the result file opens automatically, showing size, voxel 

length, porosity, and other geometric properties.  
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2.2 DIFFUSIVITY AND TORTUOSITY 

Now, let’s compute diffusivity and tortuosity using the DiffuDict module. 

1. Select Predict → DiffuDict from the menu bar.  

2. From the pull-down menu in the DiffuDict module section, choose Simulate 

Diffusion Experiment, to compute the effective diffusivity of the structure. 

Click Edit… to open the Simulate Diffusion dialog. 

 

3. Enter Diffusion_300x300x300.gdr as result file name. Nothing must be 
changed under the Constituent Materials tab. 

 

4. Under the Boundary Conditions tab, select to compute the diffusion in Y-
direction.  

Choose Symmetric (Dirichlet) Boundary Conditions in diffusion direction and 
Periodic boundary conditions in tangential directions. 
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5. Under the Solver tab, select the LIR solver and leave all its default settings. 

  

6. Click OK to close the dialog box and click Run in the DiffuDict module section to 

start the computations. 

7. When the computation finishes, the Result Viewer of the result file opens 
automatically. The Results - Report subtab shows the Relative diffusivity in 

Y-direction and the Effective diffusivity as well as the Tortuosity factor and 
the geometric Tortuosity.  

Since we ran the computations only in Y-direction, the values in X-direction and 
Z-direction appear listed as unknown in the tables. 
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2.3 EULER CHARACTERISTIC 

Now, let’s compute the Euler Characteristic using the MatDict module. 

The Euler characteristic (or Euler number) is a topological invariant, a number 

describing a topological space's shape or structure regardless of the way it is bent 
(see e.g. https://en.wikipedia.org/wiki/Euler_characteristic).  

In the context of the 3D microstructure of a separator, it can be used as a measure 

for the connectivity of the pore space. The more negative the Euler characteristic is, 
the better the pore network is interconnected. Besides porosity and tortuosity, the 

connectivity was identified as one of the most relevant parameters to determine the 
ion concentration distribution and the performance of the separator [1]. In this step, 
the Euler number is calculated using MatDict. 

1. Select Analyze → MatDict from the menu bar.  

2. Then, from the first pull-down menu in the MatDict module section, select Material 
Characterization and from the second one Minkowski Parameters to compute 

the Euler characteristic and other Minkowski parameters. 

Click the Edit… button to open the options dialog. 

 

3. Then, select MinkowskiParameters_300x300x300.gdr as Result File Name 
and compute the parameters for the pore space filled with electrolyte. 

Since our structure is not periodic, uncheck Periodic Structure. 

 

4. Click OK to close the dialog box and click Run in the MatDict section to start the 
computation. 

https://en.wikipedia.org/wiki/Euler_characteristic
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5. The Result Viewer of the result file opens automatically for the computed 

Minkowski parameters.  

The Euler characteristics are given by the last two values in the table. For the 
structure studied here both values are similar, i.e., the neighborhood mode 

selected has only a small influence on the connectivity.  
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2.4 PERMEABILITY AND GURLEY VALUE 

Now, let’s compute permeability and Gurley value with FlowDict: 

1. Select Predict → FlowDict from the menu bar.  

2. Then, from the pull-down menu in the FlowDict module section, select Stokes(-
Brinkman), to compute the flow through the structure by solving Stokes 

equations. 

Click the Edit… button to open the dialog and set the solver options. 

 

3. Enter StokesResult_300x300x300.gdr as Result File Name. Nothing needs to 
be changed under the Constituent Materials tab.  

 

4. In the Boundary Conditions tab, select to compute the flow in Y-direction and 

to use symmetric boundary conditions in flow direction. 

All other options are kept at the default values.  



Digital analysis of battery separator structures 

20  Tutorial for GeoDict 2024 

 

5. Click OK to close the dialog box and click Run in the FlowDict module section to 
start the computation.  

We run the simulation on eight cores. Running the simulation on a different 
number of cores can lead to slightly different results. 

6. The Result Viewer of the result file opens automatically, showing the 
permeability vector computed for the Y-direction.  

Again, the entries for the X-direction and Z-direction are marked as unknown in 

the table since the computation was not run for these directions.  

The Gurley value can be found under the results for the Y-direction below. 
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3. IDENTIFYING A REV FOR GEOMETRIC PROPERTIES 

The cropped segment of size 300x300x300 voxels was cut following the 

recommendation published by Lagadec et al.[1]. We want to study properties of the 
deformed geometry as done for the original geometry in the previous unit starting on 

page 12. Since the computation of a deformed geometry is costly in time and memory, 
it is convenient to use a structure as small as possible for this computation.  

In this step, we proceed to identify a REV for a structure regarding porosity and 

tortuosity. The basic idea is to compute the properties for the whole structure and for 
smaller cropped segments and compare the results. As long as the value computed 

on the small segment is the same as for the whole structure, it is enough to use the 
small segment for the computation. 

We repeat the steps outlined in chapter 1.3 Crop structure on page 10 to cut parts 

of the structure of different sizes as well as the steps in 2.1 Porosity and 2.2 
Diffusivity and tortuosity on pages 12 and 14, respectively, to compute geometric 

properties of the cut segments. 

This task can be automated. To learn how to do that, have a look at the macro file 
IdentifyingREV.py provided in the Input-Data folder of this tutorial folder. The file 

can be opened in any text editor, e.g. Notepad++. How to run the macro is shown in 
the following. If you want to do the task manually, follow the steps done in 3.1 and 

3.2 on the next page. 

1. To execute the macro, open the macro execution control by selecting Macro → 

Execute Macro /Script from the menu bar. Browse for the Input-Data folder 

and select the Python file IdentifyingREV.py.  

 

Clicking Run produces the folder IdentifyingREV inside the project folder 
Results-User. The macro loads the separator structure 8 times to crop it to the 

eight different segments and compute porosity and tortuosity on them. Finally, 
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the results are plotted into one graph inside the new folder as shown on page 25. 

On our machine with 8 cores, the macro needed 14 minutes. 

 

To learn more about automation in GeoDict, refer to the GeoPy scripting handbook 

of the User Guide. 

3.1 CROP SEGMENTS 

For each segment to cut, make sure to have the project folder set as described on 

page 3. 

1. Start always with the large structure Celgard_PP1615_WithMaterialInfo.gdt. 

Select File → Open Structure (*.gdt, *.gad)… and choose the file from the 

Results-User folder. 

2. Select Model → ProcessGeo in the menu bar. 

3. In the ProcessGeo module section, select Crop, Embed & Add Layers from the 
first pull-down menu and Crop from the second one. 

Then, click Edit… to open the options dialog. 

 

4. Choose the size of the segment that should be cut out by choosing the start and 
end voxel in each direction.  

For a segment of size 300x300x300, the values are shown in the screenshot 
below.  

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=Automation&release=2024
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The resulting structure is the Celgard_PP1615_300x300x300_3.gdt and the 
third row in the table below. 

For other structure sizes, choose the ranges shown in the following table for all 
three coordinate directions. 

 

Size of segment NX NY NZ Filename extension 

1300x650x500 0-1300 0-650 0-500 _1300x650x500_1 

500x500x500 0-500 0-500 0-500 _500x500x500_2 

300x300x300 0-300 0-300 0-300 _300x300x300_3 

300x300x300 100-400 100-400 100-400 _300x300x300_4 

300x300x300 200-500 200-500 200-500 _300x300x300_5 

200x200x200 0-200 0-200 0-200 _200x200x200_6 

100x100x100 0-100 0-100 0-100 _100x100x100_7 

50x50x50 0-50 0-50 0-50 _50x50x50_8 

 

The structures 4 and 5 are two other segments of size 300x300x300. The 

computed properties depend not only on the size of the segment chosen but also 
on the segment itself. Therefore, it is better to consider not only one segment of 

a specific size but several instead. As examples, we choose therefore 3 different 
segments of size 300x300x300.  

Save the cut segments with the name Celgard_PP1615_extension.gdt, with 
the filename extension selected according to the last column of the table 
above. 
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3.2 COMPUTE POROSITY AND TORTUOSITY FOR ALL SEGMENTS 

For each segment, perform the steps outlined in 2.1 Porosity and 2.2 Diffusivity 
and tortuosity on pages 12 and 14, respectively to determine the porosity and the 

geometric tortuosity. Load the file Celgard_PP1615_extension.gdt for each of 
the segments and choose the result file names 
StructureInformation_extension.gdr and Diffusion_extension.gdr 

accordingly.  

Results for porosity and geometric tortuosity for all segments are shown in the 

following graph, which is generated by the IdentifyingREV.py using the Python 
package matplotlib. For structure sizes larger than 100x100x100 voxels, both the 
values for porosity and for geometric tortuosity do not deviate much from those of 

the whole structure. For structure size 100x100x100 a larger deviation for the 
tortuosity value and for structure size 50x50x50 also for the porosity can be observed.  

 

Considering only the porosity and the geometric tortuosity, using the segment of size 
200x200x200 would be enough. However, since we want also to examine other 
properties for the deformed structure, we proceed here with the larger structure of 

size 300x300x300. 
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4. COMPUTING SEPARATOR-ELECTROLYTE INTERACTION 

Besides the geometric and transport properties of a separator, the interaction with 

the electrolyte is very important for the separator performance. For example, the 
thermal conductivity changes depending on the wetting of the separator with 

electrolyte.  

To show this effect, we compute the thermal conductivity for different saturations of 
the separator with electrolyte using SatuDict.  

1. Select the Results-User folder as project folder as described on page 3. 

2. Load the cropped segment of size 300x300x300 (unless it is still in memory) as 

follows: File → Open Structure (*.gdt, *.gad)… and select the 
Celgard_PP1615_300x300x300.gdt file from the project folder.  

 

3. Select Predict → SatuDict from the menu bar. 

4. Next, select Relative Thermal Conductivity in the SatuDict module section. 

5. Open the parameters dialog by clicking the Edit… button. 

 

6. Enter RelConductivity_300x300x300.gdr as Result File Name. 

Under the Wetting Parameters tab, keep the default settings of running the 

computation for five different saturation steps (0%, 25%, 50%, 75% and 100%). 
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7. On the next tab, Constituent Materials, the fluids involved in the simulation of 
the wetting process need to be defined. 

We want to simulate the wetting of the separator with electrolyte, starting with 
the pore space being full of air. Therefore, we set the material in the pore space 
to Air, by clicking on the material with Material ID 00 and selecting Air in the 

Material Selector. 
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The thermal conductivities of the materials Air and Polypropylene, available in the 

structure at the start of the simulation, are displayed on the right of this tab: 

 

Next, set the Invading Fluid to be Electrolyte that invades the structure’s pore 
space. 

 

Now the electrolyte will be the wetting phase, that replaces the non-wetting phase 
(Air) in the simulation. 

8. Under the Boundary Conditions tab, deselect Z and instead choose Y as the 
computation direction, which is the through-plane direction of the separator. Set 
the Boundary Conditions in Heat Flux Direction to Symmetric (Dirichlet), 

since the structure is not periodic in Y-direction.  

 

9. Finally, in the Solver tab, keep the default settings and click OK to close the 

dialog. 

 



 Computing separator-electrolyte interaction 

Tutorial for GeoDict 2024  29 

10. Click Run in the SatuDict section to start the computation. The computation 

took about 4 minutes on our machine with 8 cores. 

When the computation has finished the Result Viewer of the RelConductivity_ 
300x300x300.gdr result file opens. 

In the Graph Options left from the Results-Plots subtab, select the Phase for the 
plot and click Apply. By default, the graph shows the increase in relative thermal 

conductivity with increasing saturation of the separator with electrolyte.  
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5. COMPUTING THE DEFORMED STRUCTURE FOR REV 

Now, we want to study the changes of geometric properties and in separator-

electrolyte interaction if the geometry of the separator is deformed. In battery-
operating conditions a separator experiences deformation due to mechanical loads 

originating from expansions of the electrodes during charging and discharging. 

The GeoDict module ElastoDict is used to compute the deformed structure under 
mechanical load. As simplification, we assume a linear elastic behavior of the 

separator. Depending on the material of the separator, this assumption might be too 
simple to describe the real deformation. Deformation with non-linear elastic behavior 

can be computed in ElastoDict as well. 

The runtimes for the computations of geometric properties and for the separator-
electrolyte interaction on the 300x300x300 cropped segment are moderate. It is well 

possible to perform these computations on the whole structure. For the computation 
of the deformation of the separator, which is more time consuming, it is preferable to 

use the REV to run the computation. 

We compute the deformed structure for a 5% and a 10% compression.  

1. Selct the Results-User folder as project folder as described on page 3.  

2. To load the cropped segment of size 300x300x300 select File → Open Structure 

(*.gdt, *.gad)… and choose the Celgard_PP1615_300_300_300.gdt file 
from the project folder. 

 

3. Select Predict → ElastoDict from the menu bar. 

4. In the ElastoDict module section, select Deformations to compute a deformed 
geometry and click the Edit button to open the dialog for the solver options. 
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5. The Constituent Materials tab shows information on the structure materials. 

The mechanical properties of Polypropylene are taken from the material database. 
During deformation, the fluid filling the pore space (Electrolyte) can leave the 
separator and, therefore, it is not relevant for the computation of deformations.  

 

6. In the Macroscopic Load Case tab, the parameters for the deformation need to 
be defined. First, set the Experiment to Uniaxial Experiment – Compression. 

Then, define the Load Case: Since the Y-Direction is the through-plane of the 
separator, and the separator is compressed by the expansion of the electrodes, 
define the load in Y-direction.  

Next, define the Experiment Conditions: In Tangential direction, use 
Confined experiment conditions, since the separator structure continues in X-

direction and Z-direction, and the segment chosen for the computation cannot 
extend freely in these directions during compression. 

 

In the table at the bottom left of this tab, define to compress the structure by 5% 
and to apply the whole strain in one step. There are two possibilities to achieve 

this. The first method is to change the Number of Rows to 1 and enter 1 for 
Time, 5 for Strain and 0 for Temp. Change. 

In this case, the first option is fast and easy. But if we want to have many and 
more complicated steps, the table can be changed by editing the Predefined 
Shape on the right. With the choice of Linear for Shape, the compression is 

linear. Thus, it is not necessary to apply the load in several steps. Set the 
Magnitude to 5% and the Length and Number of Steps to 1. Clicking Apply 

automatically updates the table. 
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Finally, choose Mixed boundary conditions, i.e., symmetric boundary conditions 
in the load direction and periodic boundary conditions in the other directions. In 

the load direction the structure is not periodic, therefore symmetric boundary 
conditions should be used here.  

 

7. Keep the built-in default settings for the Geometry Handling, Solver and 

Output tabs.  
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8. Enter DeformationResult_5%_300x300x300.gdr as result file name and click 

OK to close the dialog.  

Click Run in the ElastoDict section. Note that the computation takes some 
minutes. On our machine with 8 cores it took about 30 minutes. Instead, you can 

also load the result from the Results-M2M folder inside the tutorial folder. 

9. The Result Viewer of the result file opens automatically at the end of the 

computations. 

 

10. Now, we run a second deformation simulation with strain of 10% instead of 5%. 
For this, in the ElastoDict section click Edit again and in the Macroscopic Load 
Case tab change the strain to 10% and the Result File Name to 

DeformationResult_10%_300x300x300.gdr. Click OK to close the dialog and 
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Run to run the deformation simulation. On our machine with 8 cores, it took about 

30 minutes. 

 

11. For both computations (5% and 10%), the deformed structures can be loaded in 
GeoDict. Choose Load for the Deformed Geometry under the Strain/Stress 
Visualization tab of the Result Viewer.  

 

The undeformed (left) and deformed geometry (middle 5%, right 10%) are shown in 

the following image.  
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6. COMPUTING PROPERTIES OF DEFORMED STRUCTURE 

Now, we compute the geometric properties and the thermal conductivity dependent 

on the separator saturation with electrolyte again for the deformed structures and 
compare them with those of the undeformed structure.  

Since the computations are the same as shown above in the second and fourth section 
(page 12 and 26), we explain here only how to access the deformed structure and 
how to compare the results in the GeoDict Result Viewer. If only interested in some 

of the results, only compute the desired properties or load them from the Results-
M2M folder. 

1. Select the Results-User folder as project folder, as described on page 3. 

2. Open one of the deformed structures by clicking File → Open Structure (*.gdt, 

*.gad)… in the menu bar and browse to the result folders of the ElastoDict 

computations  

◼ DeformationResult_5%_300x300x300 for the 5% deformation or the  

◼ DeformationResult_10%_300x300x300 for the 10% deformation.  

3. Open the file DeformedGeometry_0.gdt. Since the deformation was computed 
in one step, there is only one file for the deformed geometry available in the folder. 

 

4. Rerun the computations of  

◼ geometric properties as shown in 2.1 Porosity on page 12, 

◼ and transport properties as in 2.2 Diffusion and tortuosity on page 14, 

◼ as well as the computation of thermal conductivity dependent on the 

saturation of the separator with electrolyte as shown in Unit 4 on page 26.  

Add the suffix _Def5% or _Def10% to the name of the result file, respectively.  
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6.1 POROSITY COMPARISON 

Compare the porosity for the deformed structures with the one for the structure 
before the deformation. Open the 3 result files by choosing File → Open Results 

from the GeoDict menu bar and selecting all three result files:  

StructureInformation_300x300x300.gdr, 
StructureInformation_300x300x300_Def5%.gdr and 

StructureInformation_300x300x300_Def10%.gdr. 

In the Result Viewer, all three files can be shown at the same time, by clicking Ctrl 
and highlighting all of them.  

In the following screenshot, they are shown in the order of increasing deformation, 
from left to right. The result for the undeformed structure is shown on the left, the 

one for 5% deformation in the middle, and the one for 10% deformation on the right. 

 

The porosity of the structure decreases with increasing compression. 
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6.2 DIFFUSION AND TORTUOSITY COMPARISON 

In the same way, the tortuosity and the diffusivity can be compared as well from 
the results of the DiffuDict computations (Diffusion_300x300x300*.gdr).  

 

The diffusivity in the pore space filled with electrolyte decreases with increasing 
compression of the separator. In the same way, the geometric tortuosity of the 

structure increases. The reason for both is the decreased porosity due to the 
compression, which makes it more difficult to find a way through the structure. 

  



Digital analysis of battery separator structures 

38  Tutorial for GeoDict 2024 

6.3 THERMAL CONDUCTIVITY COMPARISON 

Next, we investigate the thermal conductivity changes for different electrolyte 
wetting levels of the structure under compression.  

1. Open the result files of all three computations of relative thermal conductivity by 
clicking File → Open Results in the menu bar, selecting the result files, and 

clicking Open (RelConductivity_300x300x300*.gdr). 

2. In the Result Viewer that opens with all three result files, select them all. The 
results are shown now side-by-side in the Result Viewer. 

3. To ensure to have the same plot settings for all three result files, in the Graph 

Options select Invading Fluid for Phase Selection and click Apply. 

 

In the dialog that opens, choose Yes to apply the post-processing settings to all 
three result files (*.gdr) simultaneously. 

  

4. For an easier comparison of the three curves, click Combine Results in the top 
right of the result viewer. 

 

5. Change the Result File Name to RelConductivity_Comparison.gdr in the 

opening dialog and click OK. 
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6. In the Results tab, select the Plots subtab. The thermal conductivity, dependent 
on the saturation of the separator with electrolyte, is shown for the structure 

before and after deformation in a single plot.  

 

The thermal conductivity decreases at high saturation rates if the structure is 

compressed. The reason is the decrease in porosity when the structure is compressed 
(see porosities for the deformed structures). Since the electrolyte has a higher 

conductivity compared to polypropylene, the overall conductivity decreases when less 
electrolyte is contained in the separator. 
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SUMMARY 

In this tutorial, the capabilities of GeoDict for digital analysis and design of Li-ion 

battery separators are shown.  

▪ The geometric and transport properties of a segmented FIB-SEM scan of a 
Celgard® PP1615 separator are calculated. Specifically, the porosity, tortuosity 

and connectivity as well as the effective diffusivity are determined.  

▪ The simulations show changes in the thermal conductivity of the microstructure 
with electrolyte wetting.  

▪ The structure is then mechanically deformed and the influence of the 

deformation on the above-mentioned parameters is monitored. 
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