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DIGITAL BATTERY CHARGING 

INTRODUCTION 

MOTIVATION 

The success of electromobility and the widespread interests in electric vehicles (EVs) 

significantly depends on increasing their transporting distance as well as the charging 
rate of their batteries. To increase both of the charging speed and capacity, 
understanding the processes on a microstructural level inside the electrodes is 

imperative. 

Unfortunately, the processes occurring in the electrodes are rather complicated and 

have not been suitably understood. Hence, employing powerful simulation software 
like GeoDict is indeed a fruitful tool in this issue. GeoDict for battery material design 
offers several features like: 

◼ Visualize 3D scans of real electrode materials, create detailed 3D models from 
scans, and analytical identification of the components of the materials, such as 

active material and binder. 

◼ Generate a statistical digital twin, and interactively change the material components 
and parameters, e.g. the binder content in an electrode.  

◼ Simulate the charging and discharging of a digital battery starting from real 
electrode materials. Predict the effect of modifying the microstructure of the digital 

electrode model and the conditions on the charging process. 

◼ Complement or replace costly and time-consuming experiments that need 
sophisticated interpretations to study the influence of a certain parameter(s) on a 

complex battery system. 

The powerful GeoDict tools offer various insightful opportunities and possibilities to 

develop and optimize battery materials. For example, it would be very easy to optimize 
the binder content of electrode materials and investigate their effects on the charging 
behavior in a short time. 

This tutorial is the last part of the Digital Battery Design tutorial series: 

1. Import and quality control of a cathode material: This tutorial guides the user 

stepwise analyzing, post-processing and finally segmenting a 3D-scan of an NMC-
cathode.  

2. Standardized microstructure analysis of a cathode material: This tutorial 

shows how to analyze the segmented scan regarding transport properties and pore 
size distribution. 

3. Building a statistical digital twin of a cathode material: In this tutorial a 
statistical digital twin is built and validated by employing the results obtained from 

the second part of this tutorial series.  

4. Digital battery charging: The charging behavior analysis in a digital battery 
consisting of bimodal electrodes is also described here. 
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In detail, this tutorial teaches the user to do the following: 

⚫ Set up a digital battery in the BatteryDict environment using predefined materials 

⚫ Charge the digital battery fully resolved and accurately using BatteryDict LIR 

⚫ Charge the digital battery on the meso-scale using BESTmeso 

⚫ Lithiation of a cathode using BatteryDict LIR 

⚫ Compare the charging behavior. 

BACKGROUND OF THE SAMPLE 

In this study, we use the Electrochemistry 3D data set NMC_94wt_600bar from the 

Laboratory for Nanoelectronics, ETH Zurich, that was used for the publication [1]. It 
stems from the project X-ray Tomography of Porous, Transition Metal Oxide Based 

Lithium Ion Battery Electrodes. Find the cropped, segmented structure with binder 
identified in the Input-Data folder of this tutorial folder. The structure ETH-NMC-
Cathode_Binder_Cropped.gdt is a result of the previous part of this tutorial series 

Building a statistical digital twin of a cathode material. 

 

The sample is used to illustrate the capabilities of GeoDict, and its module BatteryDict 

to simulate the charging of an electrode but the results are not meant to judge in any 
way the quality of the data set or physical material. 

 

 

Disclaimer: 

The work for this tutorial was not endorsed nor funded by ETH Zurich 
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HOW TO USE THIS TUTORIAL 

All operations described in this tutorial are based on the supplied files. The essential 
capabilities of BatteryDict are described in easy-to-follow steps and figures.  

We build a battery from bimodal electrodes and perform two charging simulations on 

this battery. The first one is a fully resolved method to ensure gaining accurate results, 
and the other one is relatively faster on the meso-scale.  

Afterwards, we compare the results and show when to use the faster simulation on 
the meso-scale.  

Finally, an electrode charging simulation is done on the previously mentioned cathode 

and its digital twin to show how to analyze the performance for only one electrode 
without having to build a battery. 

 

The Digital-battery-charging tutorial folder contains three folders and this PDF file. 

◼ The Input-Data folder contains the predefined data that you need to follow this 
tutorial: 

◼ One predefined anode material: BimodalAnode.gdt, in GeoDict geometry file 
format.  

◼ One predefined cathode material: BimodalCathode.gdt, in GeoDict 
geometry file format.  

◼ The cropped structure file from the previous tutorial part ETH-NMC-

Cathode_Binder_Cropped.gdt and … 

◼ …its digital twin StatisticalTwin_Cropped.gdt designed in the previous 
tutorial part. 

◼ The Results-User folder is empty and will be filled with the user’s test results 

derived from this tutorial. 

◼ The Results-M2M folder contains the results that M2M obtained by following this 

tutorial which are 5 folders and 7 files. These results (as always in GeoDict) consist 
of GeoDict result files (*.gdr) and their corresponding folders with the same names 
as following: 

 

Modules needed to follow this tutorial: 

BatteryDict 
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◼ A GeoDict result file of a battery designed from two bimodal electrodes, 
Battery_M2M.gdr. The corresponding structure file can be found in the 

folder Battery_M2M. 

◼ A GeoDict result file of the charged battery using the BESTmeso solver, 
ChargeBattery_BESTmeso_M2M.gdr, and the folder 

ChargeBattery_BESTmeso_M2M, containing detailed information about the 
computation. 

◼ A GeoDict result file of the charged battery using the LIR solver, 

ChargeBattery_LIR_M2M.gdr, and the folder ChargeBattery_LIR_M2M, 
containing detailed information about the computation. 

◼ A GeoDict result file of the lithiated cathode using the LIR solver, 

ChargeElectrode_ETHCathode_Original_M2M.gdr, and the folder 
ChargeElectrode_ETHCathode_Original_M2M, containing detailed 
information about the computation. 

◼ A GeoDict result file of the lithiated cathode of the digital twin using the LIR 

solver, ChargeElectrode_ETHCathode_Twin_M2M.gdr, and the folder 
ChargeElectrode_ETHCathode_Twin_M2M, containing detailed 

information about the computation. 

◼ A GeoDict result file ChargeBattery_Comparison_M2M.gdr that combines 
the result files ChargeBattery_LIR_M2M.gdr and 

ChargeBattery_BESTmeso_M2M.gdr. 

◼ A GeoDict result file ChargeElectrode_Comparison_M2M.gdr that 
combines the result files 
ChargeElectrode_ETHCathode_Original_M2M.gdr and 

ChargeElectrode_ETHCathode_Twin_M2M.gdr. 

We recommend that before starting to work through this tutorial, you set the folder 
Results-User as the project folder. To do so, in the GeoDict GUI select File → Choose 

Project Folder → Select Project Folder and navigate to Results-User. 
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1. CREATING A DIGITAL BATTERY 

Before starting the tutorial, it is recommended to change the GeoDict project folder 

as described on page 4.  

The first step is to build a digital battery from two electrodes, i.e. add separator and 
current collectors. In this tutorial, we use electrodes generated with the Bimodal 

Anode and Bimodal Cathode GeoApps to be found when selecting GeoApp → Battery 

→ Electrode Generation How to use these apps is described in the GeoApp handbook 

of the User Guide and in two YouTube tutorials (Creating a digital bimodal cathode 

and Creating a digital bimodal anode). With these apps, electrodes are generated to 
match the same loading. 

1. Select Predict → BatteryDict in the menu bar of the GeoDict GUI. 

2. Select Battery from the first and Design Battery from the second pull-down 
menu in the BatteryDict section on the bottom left side.  

3. Click Edit … to open the Design Battery dialog. 

 

  

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=GeoApp&release=2024
https://www.youtube.com/watch?v=fvipFn0zPTE
https://www.youtube.com/watch?v=zemaM6UxoMM
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4. Change the Result File Name to Battery.gdr. 

Under the Geometry tab, a 3D scheme of a typical battery is shown. Below the 

Anode and Cathode sections, click the Browse… buttons to navigate to the Input-
Data folder and load the predefined electrode materials into the battery designer.  

 

Select BimodalAnode.gdt for the anode and BimodalCathode.gdt for the 
cathode. 

5. In the Anode and Cathode tabs, the constituent materials are controlled. Check 

that the selected materials for the battery are the following: 

◼ Anode: 

◼ Anode ID 00: Electrolyte 

◼ Anode ID 01: Graphite (as active material) 

◼ Anode ID 02: Graphite (as active material) 

◼ Anode ID 03: PVDF Binder + Carbon Black (as binder) 

◼ Cathode: 

◼ Cathode ID 00: Electrolyte 

◼ Cathode ID 01: NMC333 (as active material) 

◼ Cathode ID 02: NMC333 (as active material) 

◼ Cathode ID 03: PVDF Binder + Carbon Black (as binder) 

 

 



 Creating a digital battery 

Tutorial for GeoDict 2024  7 

 

6. Click OK to close the Design Battery dialog and then, click Design in the 
BatteryDict section. When it is finished, the structure is generated accompanied 

by the Result Viewer window, which open automatically. The Result Viewer 
window shows the volume fractions of the constituent materials. 

7. In the visualization area, a 3D-view of the battery can be seen. To see the 3D view 

of the generated structure, click on the 3D icon  in the toolbar.  

8. The colors of the materials can be adjusted through the Color & Visibility tab 
located on the right side bar. Herein, the following colors are selected to get our 

desirable material visualization. 

 

The colors intensity for ID 03 and ID 09 are slightly lighter than the Gray (ID 02) 
and Light gray (ID 08).  
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To obtain these colors, that are not predefined as basic colors, do the following: 
Set the color of ID 03 to Gray by clicking on the color button. Then, click again on 

this color button and expand the color menu by clicking on the three dots. 

Adjust the gray color by pulling up the triangle slider on the right, next to the gray 

scale bar and see the color changes. To reproduce the same color for ID 09, copy 
the HTML code from ID 03 (we chose #a8a8ac) and paste it for ID 09. 

 

9. In the View Controls, go to the Structure tab and choose Structure Renderer 
as Smooth. 

 

10.Switch to the Camera tab and make the following settings: 

⚫ Rotation BNK: 20 

⚫ Translation Z: 3 
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⚫ Set the rest to: 0 

⚫ Check Show Halo 

 

The digital battery is now functional and ready to charge with a very nice 
visualization. 
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2. CHARGING THE DIGITAL BATTERY 

In this section, a charging simulation is carried out on the digital battery using 

BatteryDict LIR. The LIR solver is a very fast solver for a fully resolved simulation, 
which leads to a very accurate charge curve and resolved solution outputs. 

In the BatteryDict section select Charge Battery from the second pull-down menu. 

Click Edit… 

 

1. In the opened Charge Battery dialog, set ChargeBattery_LIR.gdr as Result 

File Name. 
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2. In the Constituent Materials tab, check that the materials are set correctly. 
Otherwise, you can change the constituent materials by clicking on the material 

name and selecting the correct material.  

3. In the Experiment tab, set the Range of the Cell State of Charge to be from 

40.00% to 60.00%. 

 

With these settings, the battery will be charged with a charge rate of 1 starting 
with an SOC of 40% and ends at SOC of 60%. Charging means lithiation of the 

anode and delithation of the cathode. 

4. Change to the Solver tab and select LIR as Solver Type. 

 

5. Click OK to close the dialog and then click Charge in the BatteryDict section.  

 

 



Digital battery charging with GeoDict 

12  Tutorial for GeoDict 2024 

It takes around 1 hour to complete the simulation on 8 processing cores.  

At the end, the ChargeBattery_LIR.gdr file is generated together with the folder 

ChargeBattery_LIR in the Results-User project folder. The results will be discussed 
on page 17. 

For detailed information about all options of the Charge Battery dialog, refer to the 
BatteryDict handbook of the User Guide. 

 

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=BatteryDict&release=2024&heading=ChargeBattery
https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=BatteryDict&release=2023&heading=ChargeBattery
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3. CHARGING THE DIGITAL BATTERY ON A MESO-SCALE 

The previous charging computation was based on the voxel geometry and thus fully 

resolves the battery. We also provide a pseudo-2D Newman Model Simulation with 
the BESTmeso solver. Although it does not fully resolve the structures within the 
battery cell, it can provide a reasonable approximation for the charging-curve and 

takes relatively shorter calculation time. 

In this model, BatteryDict first calculates geometry dependent input parameters, such 

as ionic diffusivity and ionic conductivity in the different materials. With these effective 
parameters, this method is able to consider various characteristics of anode and 
cathode.  

In the next step, the battery structure is then composed of representative effective 
voxels. These voxels are arranged in 1D in the X-direction. Each of these voxels 

contains a sphere-shaped representative active particles for each active material. The 
effective radius of these spheres is calculated using the effective parameters and gives 
a second degree of freedom. This has no spatial dimension and is thus called “pseudo-

dimension”. Therefore, the method is called pseudo-2D. With the effective active 
material particles, it is possible to simulate the amounts of lithium diffusion into or out 

of the active material. This means, the battery equations are solved on the simplified 
structure with less computational effort compared to the fully resolved simulation. 
Additional information is found in the BatteryDict handbook of the User Guide. 

1. In the BatteryDict section, click Edit… to open the Charge Battery options 
dialog. The settings for the materials and the experiment are the same as described 

in the previous chapter starting on page 10. 

2. Change the Result File Name to ChargeBattery_BESTmeso.gdr.  

 

3. In the Solver tab, change the Simulation Type to Homogenized Simulation. 

Then, the BESTmeso solver is selected automatically for the Solver Type. 

4. Click OK, and in the BatteryDict section click Charge to start the simulation. 

The simulation will be performed far faster (in about 1 minute on 8 processing cores) 
benefitting from similar results that are obtained from the LIR solver, as is shown in 
the result analysis chapter on page 17. 

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=BatteryDict&release=2024&heading=ChargeBattery
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4. LITHIATION OF A CATHODE 

In this section, we show how to simulate only one electrode, e.g. the NMC-cathode. 

For this purpose, the lithiation of the NMC-cathode, which takes place during discharge 
of the full battery, is investigated. This is very useful, if only one electrode should be 
analyzed instead of a whole battery cell.  

In addition, it is not necessary to use Design Battery for this purpose. BatteryDict adds 
separator, current collectors and a lithium reservoir as an anode as its default 

geometry. Electrochemically, the investigated electrode is always considered as 
cathode. 

We use the cathode structure and its digital twin created in part 3 of the Digital 

Battery Design tutorial series. Provided in the Input-Data folder is the cropped 
original cathode structure and the cropped digital twin of the cathode.  

If you worked through the previous tutorials of this series, you may also crop these 
structures manually. For this select Model → ProcessGeo and in the ProcessGeo 

section, select Crop, Embed & Add Layers from the first pull-down menu. Select 

Crop from the second and click Edit…. Enter the settings shown here and click OK 
and then Crop.  

 

1. Click File → Open Structure (*.gdt, *.gad) … in the menu bar. Choose the file 

ETH-NMC-Cathode_Binder_Cropped.gdt from the Input-Data folder to be 

loaded into GeoDict.  

 

2. Choose Electrode from the first pull-down menu and Charge Electrode from 

the second in the BatteryDict section. Then, click Edit…. 
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3. Change the Result File Name to ChargeElectrode_ETHCathode_ 
Original.gdr.  

 

4. In the Experiment tab, choose Lithiate Electrode as Experiment Type. Set the 
Range of the electrode state of charge to be from 40.00% to 60.00%. 
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5. Go to the Solver tab and select LIR as the Solver Type.  

 

6.  Click OK and then Charge in the BatteryDict section to run the simulation.  

The simulation finishes in about 30 minutes on 8 processing cores. 

7. Then, load the StatisticalTwin_Cropped.gdt file in the GeoDict GUI (File → 

Open Structure (*.gdt, *.gad) … in the menu bar). 

8. In the Charge Electrode dialog, change the Result File Name to 
ChargeElectrode_ETHCathode_Twin.gdr. The other settings are the same as 

for the previous run. 

 

9. Click OK and then Charge in the BatteryDict section to start the simulation. 

The simulation finishes in about 30 minutes on 8 processing cores.
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5. RESULT ANALYSIS 

For each completed simulation, the corresponding result file is opened in the Result 

Viewer of the .gdr result file.  

1. Go to the Results → Plots subtab, to observe the Charge curves.  

2. Select the Cell Potential over cell state of charge from the pull-down menu to 

see the following curves: 

◼ Cell potential while charging (red curve). 

◼ Evolution of the equilibrium cell potential (blue curve). 
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CHARGE BATTERY RESULT ANALYSIS 

Use the combine .gdr functionality of the Result Viewer to compare the results of 
the BatteryDict with LIR and BESTmeso solvers simultaneously.  

1. Press and hold CTRL-key.  

2. Select the ChargeBattery_LIR.gdr and ChargeBattery_BESTmeso.gdr result 
files and then, click Combine Results. 

3. In the Combine Results dialog, change the Result File Name to 
ChargeBattery_Comparison.gdr and then, click OK.  

 

4. Go to the Plots subtab of the combined .gdr files to observe the combined charging 

curves.  

The curve resulting from the simulation with the LIR solver is shown in blue and 

the one from the BESTmeso solver is in red. 
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See how the result of the BESTmeso solver is relatively similar to the fully resolved 
simulation with a significantly faster calculation time (1 minute vs. 1 hour!). 

Consequently, as an example case of the bimodal electrodes, choosing the pseudo-2D 

Newman model simulation is preferred.  

However, if you want to visualize the 3D result fields such as the lithium ion 

concentration or the ionic diffusion for several intermediate charging steps, choose 
the fully resolved model. 
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CHARGE ELECTRODE RESULT ANALYSIS 

In the next steps, we carry out the 3D visualization of the results from the Charge 
Electrode simulation.  

For this purpose, select the result file ChargeElectrode_ETHCathode_Twin.gdr. 

1. Visualize the results for the third time step by going to the Data Visualization 
tab, choosing 3: Electrode SOC 40% from the pull-down menu, and clicking Load 

Cell_2.cap. 

 

Now, select only the components that you wish to visualize. Here, the DiffusionFlux 
that is visualized as a default volume field, as well as the Lithium-Ion concentration in 

the solid materials are chosen. 

In the dialog, click Uncheck all to de-select all components and then, select 

ConcentrationSolid:ConcentrationSolid and IonicFluxDensityElectrolyte: 
IonicFluxDensityElectrolyte. Click OK.  
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As it is shown here, the battery cell microstructure generated in GeoDict contains a 
separator, lithium reservoir anode, NMC cathode, and current collectors.  

 

In the above picture, the colors are selected as following: 

 

2. To see the 2D view, click the 2D icon  in the toolbar. 

3. Select View → Legends / Overlays from the menu bar. In the opened window, 

deselect Material Legend. 

4. Uncheck the Structure tab in the Visualization panel above the Visualization area 
and go to the Volume Field tab. From the pull-down menu for Visible on Material 
IDs, uncheck Material IDs 01, 02, 08, 12 and 13 to only visualize the diffusion in 

the electrolyte and the separator, as the diffusion is 0 mol/m²s in all other 
materials. 
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5. Go to the Camera tab and select Y as Direction. Scroll through the slices with the 
mouse wheel or with the slider in the Visualization panel.  

The results indicate that in all slices, the diffusion values near to the separator are 

higher than those around the cathode current collector.  

 

6. Hover the cursor over the volume field to see the exact diffusion flux values and 
the materials in the corresponding voxels.  
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7. Go to the Volume Field tab. In the Color By option, select ConcentrationSolid 
to view the ion concentration of the solid in the battery structure. 

 

8. Select ID 08 and 12 again for Visible on Material IDs to visualize the ion 
concentration in the NMC particles and the binder phase. 

 

The colors indicated that the local concentration in the electrolyte is low, while in 

the NMC particles is in the highest value. In addition, the larger grains have a lower 
concentration than the smaller particles. The binder phase has the same 
concentration as the electrolyte, due to its porous model. 

 

9. To compare the results of the Charge Electrode simulations, load the 
ChargeElectrode_ETHCathode_Original.gdr and 
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ChargeElectrode_ETHCathode_Twin.gdr files and combine them in the Result 
Viewer as shown previously.  

Click Combine Results and select the Result File Name to be 
ChargeElectrode_Comparison.gdr 

 

As was shown before, compare the charging curves for the original cathode 

and its digital twin. They are fairly similar. 
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CONCLUSION 

In this tutorial, we have shown how to simulate and analyze the charging behavior of 

a digital battery consisting of bimodal electrodes.  

For the digital battery used in this tutorial, the resulting charging curve from the 
BESTmeso solver is very close to the charging curved obtained with the LIR solver. 

When no result fields or slice mean plots are needed, the BESTmeso is a good and 
fast tool to analyze the performance of a battery with these materials.  

To find out whether this finding holds for your own setup, test the simulation with 
cropped (but still representative) electrodes and compare the results of the LIR and 
the BESTmeso solver according to this tutorial. If the results are close, simulating on 

larger cutouts may be performed using the BESTmeso solver with high accuracy. 

The tutorial series Digital Battery Design enable the users to import and segment 

scans from a real electrode microstructure to create, charge, and analyze a statistical 
Digital Twin in GeoDict. The series consists of the following tutorials: 

1. Import and quality control of a cathode material: stepwise guide to analyze, 

post-process and segment a 3D-scan of a NMC-cathode.  

2. Standardized microstructure analysis of a cathode material: stepwise guide 

to analyze the segmented scan regarding transport properties and pore size 
distribution. 

3. Building a statistical digital twin of a cathode material: building of a 

statistical digital twin and validation using the results from the Standardized 
microstructure analysis of a cathode material tutorial.  

4. Digital battery charging: Learn how to analyze the charging behavior of a digital 
battery consisting of bimodal electrodes. 

 

Our Electrochemistry - Batteries Team is eager to help you discover the features of 
GeoDict and of BatteryDict for the design of battery materials. 

Contact us: Ilona Glatt and Roman Buchheit.  

https://www.geodict.com/service-support/learning-opportunities/tutorials.html
mailto:ilona.glatt@math2market.de
mailto:roman.buchheit@math2market.de
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